话说现在写PHP的用composer的多不多啊,我有一个问题请教大神

我有一个问题:一般是在项目目录的vendor目录下创建composer.json文件,里面有要引入的包,命令行切换到vendor目录下面,composer update就会下载这些依赖,下载的包会在vendor目录下面,但是如果包之间相互依赖,而出现依赖相同的包,但是不一样的版本,那怎么办呢,这不就冲突了吗?

比如我要引入A包和B包,他们又同时依赖C包,A依赖C 1.0.0版本,B依赖C 2.0.0版本,那这样C包不冲突了吗,如果vendor目录下面的包目录是带版本号就好了,不然可怎么办呢?

同一个包,不指定版本的话,通常是下载的最新的版本,需要中间版本,可以指定版本。

具体规则如下:

  1. 确切的版本号 1.0.2 你可以指定包的确切版本。

  2. 范围 >=1.0 >=1.0,<2.0 >=1.0,<1.1|>=1.2 通过使用比较操作符可以指定有效的版本范围。 有效的运算符:>、>=、<、<=、!=。
    你可以定义多个范围,用逗号隔开,这将被视为一个逻辑AND处理。一个管道符号|将作为逻辑OR处理。 AND 的优先级高于 OR。

  3. 通配符 1.0.* 你可以使用通配符来指定一种模式。1.0.与>=1.0,<1.1是等效的。

  4. 赋值运算符 ~1.2 这对于遵循语义化版本号的项目非常有用。~1.2相当于>=1.2,<2.0。想要了解更多,请阅读下一小节。

上面的「未注册用户」说了些干货,但是似乎理解错了题主的意思。 题主的意思应该是,两个包(比如 AB)同时依赖与第三个包(比如 C),但是依赖的版本并不同(比如 A 依赖 C 1.0B 依赖 C 2.0),怎么解决冲突的问题。

我的答案是,没法解决。在同一个项目中,某个包的版本肯定是固定的。
无论是用了 精准版本号范围版本赋值版本号 之类的方式指定版本,在 composer require 或者 composer install 之后,本地的包的版本一定是有一个准确版本号了。不可能运行时做到 A 使用 C 的时候 C 就是 1.0B 使用 C 的时候 C 就是 2.0

所以唯一的办法就是找到一个 AB 都能用的 C 的版本。如果不能,不好意思,包冲突,无法运行。


补充说明,这个C版本冲突其实是代码逻辑的冲突,不是简单的文件夹冲突,靠改变文件夹是没法解决的。
以我上面举的例子说明,假如包 C 定义了一个常量 C_VERSION,这个常量的值表示 C 本身的版本号字符串。

那一个同时加载了 AB 的程序运行的时候,输出 C_VERSION,到底是 1.0 还是 2.0 呢?

真实常见的情况是,程序运行报错,因为两次引入不同的包 C 发生冲突,报 notice,然后谁先加载就是谁。

这代码也就太乱了。

难道大家这个用得还不多吗,不会吧

  • Laravel如何使用Juicer
  • PHP:这个文件该如何解密呢?
  • php 对 mysql 数据库遍历的问题
  • 求教我在这种情况下,该怎么跳到登录页面不报错?yii2里
  • highcharts drillup上钻问题
  • Hbuilder链接远程服务器使用sftp协议,所需的公匙怎么获得。求大神指教。
  • VideoJs 在chrome里报错
  • phpQuery获取网页里的js变量,如何获取
  • Linux服务器瞬间生成巨量session文件撑满硬盘,请问有什么办法解决?
  • php和java联合开发一个网站后台逻辑
  • 用Javascript在浏览器端能实现指纹识别吗?